This project is read-only.

imap without ssl with port 143

Jun 30, 2015 at 7:28 PM
Hey! I tried to download messages from folder inbox. Connecting and loging are good and he shows right count messages in the inbox (EXISTS), but couldn't to access any message.
This is debug output

  • LIST (\HasNoChildren) "." "Trash"
  • LIST (\HasNoChildren) "." "INBOX"
    IMAPX3 OK List completed.
    IMAPX4 EXAMINE "Trash"
  • FLAGS (\Answered \Flagged \Deleted \Seen \Draft NonJunk)
  • OK [PERMANENTFLAGS ()] Read-only mailbox.
  • 1 EXISTS
  • 1 RECENT
  • OK [UIDVALIDITY 234234] UIDs valid
  • OK [UIDNEXT 386] Predicted next UID
  • OK [HIGHESTMODSEQ 10] Highest
    IMAPX4 OK [READ-ONLY] Select completed.
  • OK [CLOSED] Previous mailbox closed.
  • FLAGS (\Answered \Flagged \Deleted \Seen \Draft Junk NonJunk)
  • OK [PERMANENTFLAGS ()] Read-only mailbox.
  • 81 EXISTS
  • 0 RECENT
  • OK [UNSEEN 1] First unseen.
  • OK [UIDVALIDITY 1234234] UIDs valid
  • OK [UIDNEXT 34234] Predicted next UID
  • OK [HIGHESTMODSEQ 234234] Highest
    IMAPX5 OK [READ-ONLY] Select completed.
Can you help me?
Jul 8, 2015 at 2:08 PM
what do you mean by "could not access any messages"? You are opening the Trash and INBOX folders as read-only, which means you won't be able to change any flags if that's what you mean.
Jul 9, 2015 at 11:44 PM
Hi makarti,

from your log, I do not see that you have tried to access any messages. It only contains the folder listing which is done after a successful login. Can you provide the full log and the piece of code you are using?


Sep 11, 2015 at 10:32 AM
it's good, I hasn't called method Search()
Marked as answer by makarti on 9/11/2015 at 2:32 AM