Issue receiving the Attachment

Topics: Issues
Dec 18, 2013 at 2:24 PM
Hi,

i used an earlier version of ImapX to extract XML Attachments, so that they can be processed. Those attachments had always issues in the latest version with the last few characters at the end of the attachment, but i worked around that.

Now i updated to the new version 2.0.0.15 but i dont get them anymore as attachment, but they are in the body. Also the returned Content has additional characters like '* 1 FETCH (' and ' UID 40 ' and they need to be removed before i can do the base64 encoding. Is that intended and will this stay like this?

Thx
Coordinator
Dec 18, 2013 at 3:13 PM
Hi spacey1982,

in order to fix this issue, i need to know the structure of your message. Please download the sample application from here: http://imapx.org/ImapX.Sample.zip

In the message context menu there's an option to show the body structure. Please copy it and post it here. (As code!)

Thanks,

Pavel
May 8, 2014 at 2:11 PM
Hi Pavel,

Im using ImapX2 to extract XML Attachments, those attachment had always issues removing white spaces or adding characters. Please help me.

Thanks,

Roberto
Coordinator
May 11, 2014 at 9:22 AM
Hi Roberto,

sorry for the delay, been busy these days.
Which version of ImapX are you using? have you tried the latest (2.0.0.16)?

Greets,

Pavel