This project is read-only.

IMAPX Error when deploy my app [CAPABILITY IMAP4rev1...]

Jun 12, 2013 at 9:53 PM
Hi guys,

I Made an application in MVC that works fine on my computer. When i Publish the App to my Windows 2008 Server i got that error:

System.Exception: * CAPABILITY IMAP4rev1 UNSELECT IDLE NAMESPACE QUOTA ID XLIST CHILDREN X-GM-EXT-1 XYZZY SASL-IR AUTH=XOAUTH AUTH=XOAUTH2 at ImapX.ImapBase.SendAndReceive(String command, ArrayList& sResultArray) at ImapX.ImapBase.SendAndReceive(String command, ArrayList& sResultArray) at ImapX.ImapBase.Capability() at ImapX.ImapBase.Connect(String sHost, Int32 nPort, Boolean useSSL, Boolean validateCertificate) at ImapX.ImapBase.Connect() at ImapX.ImapClient.Connection()

Any tips?
Jun 13, 2013 at 7:50 AM
Hi lucianotcorreia,

I tested the library on Server 2008, and it works fine, but I didn't have a web application.

The only problem i could think of here, is that the ImapClient is losing connection and can't call the capability command (first command after connection). The exception has no detailed stacktrace, which makes it hard to analyse.

I compiled a version of the library under debug configuration for you, and removed some internal exception handling. Can you try deploying your project using this version of the library? (don't forget to include the *.pdb file). It will give us a detailed stacktrace, so I can fix the issue faster.

Link to download the library: https://mega.co.nz/#!8l5UnRyZ!XVnuhlSFp5w0-5bOpuG6eHGwDI1NGd6bF8P39NrPESQ


Best regards,

Pavel Azanov
Jun 13, 2013 at 7:55 PM
Edited Jun 13, 2013 at 7:55 PM
Thanks for the replay pavel.

i tried to make a Console App, and set the IsDebug Protperty to true.

Run the App in my computer and is Ok. Uploaded to my server and got that error message now:

IMAP002 NO [ALERT] Please log in via your web browser: http://support.google.com/mail/accounts/bin/answer.py?answer=78754 (Failure)

Any Tips?
Jun 13, 2013 at 8:19 PM
Update: The link has an option for "Clear Captcha" after that my app and site worked fine on the server.
Jun 14, 2013 at 7:45 AM
Good day!

thank you for checking! Happy you found a solution. I think Google sometimes blocks direct access to an account for security reasons. I'll consider this issue in the next release.

Best regards,

Pavel Azanov